v3.0.1

Aug 7, 2016 5:14 pm EDT

Choose your Postgres

Choose your Elasticsearch

Choose your Linux

v3.0.1

v3.0.1 Release Notes

v3.0.1 is a minor update to v3.0.0 that fixes a few bugs and implements a few minor feature enhancements. ZomboDB now includes pre-built artifacts for Debian Jessie.

A REINDEX is not required when upgrading from v3.0.0. If upgrading from the v2.6 series, please see the v3.0.0 release notes

Bug Fixes

  • Issue #132: Queries that use nested #expand constructs would drop records. They no longer do.
  • Issue #129: ZomboDB now builds/releases debian_jessie artifacts and the included Dockerfile uses this artifact.
  • A bugfix to Queries that ANDed together terms AND "quoted phrases" where ZDB would inadvertently rewrite them with an OR connector.

New Features

  • Issue #133: Support for the Postgres contrib extension datatype citext
  • Issue #134: ZomboDB can now query Elasticsearch "multi-fields", if they're defined in a custom field mapping

Thanks

Thanks to everyone who reported bugs and suggested features!

Stop waiting.
Start searching.

Get Started Today